Site Overlay

卸载安装替换为指定版本OpenSSL

需求

安装ss代理时编译报错,经查询是openssl版本问题导致编译失败,故卸载替换当前版本重新安装
#查找当前安装的OpenSSL版本
rpm -qa|grep ssl

#指定对应版本进行卸载
yum -y remove openssl-1.1.1g-15.el8_3.x86_64
#可以去该地址下载自己想要的版本的OpenSSl
https://www.openssl.org/source/old/1.0.2/openssl-1.0.2u.tar.gz
#解压
tar -zxvf openssl-1.0.2u.tar.gz
#进入目录
cd openssl-1.0.2u/
#编译安装
./config --prefix=/usr/local/ssl
make && make install
#修改软连接
ln -s /usr/local/ssl/bin/openssl /usr/bin/openssl 
ln -s /usr/local/ssl/include/openssl /usr/include/openssl
#查看版本
openssl version -a 

发表评论

邮箱地址不会被公开。 必填项已用*标注

A beliving heart is your magic My heart
Copyright © 2022 Diuut. All Rights Reserved. | Catch Vogue by Catch Themes | 蜀ICP备2021011635号-1 | magnet:?xt=urn:btih: